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INTRODUCTION
Welcome to CINEMA 4D. The aim of this book is to introduce you gently to
many of CINEMA 4D’s powerful features, from the basic functions all the way
up to some exciting rendering and animation techniques.

This book contains two tutorials. First we are going to create a scene using
objects, materials, textures and lights. In creating this scene we will learn the
basics of modelling and raytracing—we’ll use all of the fundamental CINEMA
4D functions, and a few of the more advanced ones. In particular we’ll gain
valuable experience with the toolbar buttons, the object manager and the
material manager. We are going to learn how to apply textures and even how
to create our own materials from scratch.

In the second tutorial we’ll learn how to excite this static scene into life by
using some simple but nonetheless spectacular animation techniques.

The scene tutorial should take about 60-90 minutes for you to complete; the
animation tutorial will take considerably longer as there will be multiple frames
to render. Both tutorials are structured so that you can stop at any time and
later pick up where you left off. For every section of both tutorials we have
indicated how long we estimate it will take you to work through that section.

We hope you will enjoy your first steps with CINEMA 4D. As you work through
this book we know that all sorts of imaginative ideas for future projects will
jump into your head. At this stage you don’t know the program and you may
be unsure if what you are imagining is possible to do in CINEMA 4D. We can
confidently predict that it will be simply a matter of how it is done rather than
can it be done. When you have finished working through the tutorials in this
book, you will be well down the road to becoming a master modeller.

Mouse buttons
We recommend that you use a two-button mouse with CINEMA 4D. These
can be hard to come by for the Macintosh, so if you are using a single-button
mouse and you read “...using the right mouse button”, you can simulate this
action by holding down the Command key (also called the Apple key) while
using the single mouse button.

CINEMA 4D’s Windows™ interface.

CINEMA 4D’s Macintosh interface.



8 CINEMA 4D QUICKSTART

Toolbars
The Windows version of CINEMA 4D uses toolbars that are docked—that is,
they attach themselves to the appropriate window and move when the window
to which they are attached moves. These toolbars can be positioned inside or
outside a window. To save space, when a toolbar is docked within a window its
outline will be removed. To remove a toolbar from the screen, position the
mouse pointer over the toolbar, click the right mouse button and select Remove
from the pop-up menu.

The Macintosh operating system (Mac OS) has no docking function, instead
the toolbars float over the other menus and will never be obstructed from view.

Local Menus
The menu bar is quite different for Macintosh and Windows versions. Every
Manager window has its own “local” menu bar. In the Windows version this
menu bar is situated beneath the title bar of each window. In the Macintosh
version there is just one menu bar situated along the top of the screen; the
appropriate local menu will appear there depending on which Manager window
is currently active.

In the Mac version only, in order to reduce the number of mouse miles you
have to travel when using high resolutions or multiple monitors, hold down the
Alt key while clicking the mouse button to open the local menu for the active
window as a pop-up menu at the current position of the mouse pointer.

Dialog Pages
In some dialogs you can switch between several pages of options. In the Windows
version this follows the tabbing principle—the page titles are on tabs along the
top of the dialog. In the Macintosh version, switching between pages is achieved
by selecting them from the pop-up menu at the bottom left of the dialog.
Alternatively you can use the arrow buttons to flip through the pages.

The Windows version allows you to attach
the toolbars to either the inside or outside of

windows.

The Macintosh version allows you to pop-up
local menus by holding down the Alt key

while clicking the mouse.

The Macintosh version lists dialog pages in
pop-up menus at the foot of dialogs.

The Windows version lists dialog pages on
tabs along the top of the dialog.



CREATING
A SCENE
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1. CREATING A SCENE

At this early stage we don’t want to burden you with advanced drawing
techniques, so the scene we are going to create is going to use simple objects
that we can create quickly and manipulate easily. Simple objects or not, we can
use CINEMA 4D to turn mundane shapes into “living” 3D objects.

This is the scene we are about to create.
CINEMA 4D will do all the hard work for us.
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We will create a scene that has a floor and a sky. On the floor we will sit a plinth
and on the plinth we will sit a crystal ball. In front of the plinth we will stand
some metallic lettering. Using materials, textures and lighting we will discover
that you can turn a pig’s ear into a silk purse.

The Sphere
1 After running CINEMA 4D, create a sphere by selecting Sphere from the

Objects>Base Objects menu. (Mac: If you cannot see an Objects menu
title it will be because the Scene Editor window is not active. Click in the
Scene Editor to activate its local menu.) Press OK to accept the default
values after ensuring that the Perfect Sphere option is selected (has a tick
next to it).

A white wireframe sphere will appear in the Scene Editor, surrounded by a red
cube—the red cube is CINEMA 4D’s way of letting you know which object is
currently selected. Notice that the sphere has also appeared as an entry in the
Object Manager. Don’t worry about the meaning of the little icons at this stage,
you can read all about them later in the main CINEMA 4D Reference Manual.

The wireframe display has the advantage of being very quick, but pretty soon
you’ll discover that you need to see a solid representation of objects in order to
get a better feel for what you are doing. CINEMA 4D has several display modes,
but the one you’ll probably use most while working on your scenes is Gouraud
Shading.

In the Objects>Base Objects sub-menu
you’ll find the basic building blocks from

which objects are created.

This section will take about
10 minutes to complete.
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2 Select Gouraud Shading from the View>Display Mode menu. (Mac: If you
cannot see a View menu title it will be because the Scene Editor window is
not active. Click in the Scene Editor to activate its local menu. This is the
last time we are going to remind you that each window has its own local
menu.)

The wireframe sphere will turn into a solid, shaded white sphere. From now
on, when the Scene Editor is at rest—when you aren’t editing the scene in
other words—CINEMA 4D will quickly use Gouraud Shading to change
wireframes into solids. If at any time you want to force CINEMA 4D to shade
the scene—say because you’ve interrupted CINEMA 4D so that the scene is
only partly shaded—then you can use the Redraw button to make CINEMA 4D
refresh the Scene Editor window.

3 Press the Redraw button.

The sphere quickly turns into a wireframe and then just as quickly gets Gouraud
Shaded again.

There are several display options. Wireframe
is the fastest, but Gouraud shading gives you

a better feel for the scene.

The Redraw button.
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Now we want to raise the sphere a little so we can put a plinth underneath it.
Moving an object accurately is very difficult to achieve in the 3D view, so let’s
change to the 4-Way-View (4T) view in which it is much easier to move objects.

4 Press the 4-Way-View button.

The Scene Editor changes so that you now have four views of the object—the
3D view (top left), a view from above (top right), a view from the side (bottom
left), and a view from the front (bottom right). Because the sphere is completely
symmetrical, the above, side and front views of it look the same, but notice that
the axes are labelled differently. In CINEMA 4D, Y is the vertical axis (up-and-
down), X is the horizontal axis (left-and-right), and Z is the depth axis (toward
you and away from you. Let’s move the sphere.

5 Press the Edit Object button (underneath the Edit Camera button).

If we don’t press the Edit Object button then we will end up moving the camera
instead of the object.

As all we want to do is raise the sphere—move it along the Y axis in other
words. We can ensure that we don’t move it along either of the other two axes
by locking them while we perform this operation.

6 Press the X axis and Z axis buttons so that the buttons appear raised or
“switched off”.

The Axes buttons, with X and Z locked or
“switched off”.

The 4-Way-View (4T) button.

The Edit Object button.
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7 Click in the bottom left quadrant of the Scene Editor (the side view) and
while holding down the (left) mouse button push the mouse away from
you until the bottom of the sphere is about halfway to the first grid line
above the Z axis.

Moving the mouse while holding down the mouse button is called “dragging”
the mouse. From know on we will use that term.

Notice that the 3D and front views also move as you move the object in the
side view. The from-above view doesn’t change because the object is not moving
along either the Z or X axes, just the Y axis.

OK, that’s it, we’ve finished with the sphere for the moment. Next we’ll create
the plinth, but before we do that, let’s save what we’ve got so far.

8 Select Save from the File menu, select a folder, give your work a filename,
press the Save button.



16 CINEMA 4D QUICKSTART

The Plinth
For the crystal ball’s plinth we are going to use an ordinary cube object and
flatten it a bit. Later we’ll give it a texture (as we will everything else), but for
the moment all we are concerned with is creating the various objects that
comprise our scene.

1 Hold down the Shift key and select Cube from the Objects>Base Objects
menu.

We now have a cube in our scene and it is sitting under the sphere. Let’s
reshape the cube.

2 Ensure that the cube is the selected object (click on its name in the Object
Manager).

3 Ensure that the Edit Object button is selected.

4 Press the Scale button.

As all we want to do is squash the cube a little—scale it along the Y axis in other
words—once again we can lock the X and Z axes.

5 Press the X axis and Z axis buttons so that they appear raised or “switched
off”.

6 Click in the 3D view and drag the mouse slowly to the left until the height
of the plinth is about one-third its width. (Remember, dragging means
moving the mouse while holding down the mouse button.)

Now we’ve got the shape we want, but it is not positioned correctly. We need
to raise the plinth so that it sits smack on the X axis (which is where our floor
will be).

7 Press the Magnifying Glass button and click in the front view (bottom right)
just above and to the left of the top left corner of the plinth. Drag the
mouse just below and to the right of the bottom right corner of the plinth.
Then let go of the mouse button.

We have zoomed in on the plinth so that it is easier for us to position it accurately
using the mouse. Notice that the 3D view remains as it was; this is because the

Holding down the Shift key while selecting
an object from the Base Objects sub-menu is

a time-saving technique to bypass the
object’s parameters dialog

This section will take about
5 minutes to complete.

The Magnifying Glass button.

The Scale button.



17CINEMA 4D QUICKSTART

3D view is always the view as seen from the camera, and as the camera position
hasn’t changed, neither has the 3D view changed.

8 Click on the Move button.

9 If they are not already locked, press the X axis and Z axis buttons so that
they are locked.

10 Click in the front view window (bottom right) and drag away from you
until the white line of the plinth’s base is sitting on the X axis.

OK, so now the plinth is almost where we want it and the sphere should be on
top of the plinth and slightly sunk into it. In a moment we are going to rotate
the plinth and the camera view into the positions we want them, but as rotating
is new to us and we might muck it up, this seems like a good time to save our
work so we can revert to it when we do muck it up. Let’s zoom out first...

11 Press the Magnifying Glass and click in the front view with the right mouse
button. With the right mouse button held down, drag the mouse down
and to the right so that the box you are dragging is about the same
dimensions as one of the grid squares. Then let go of the right mouse
button. (Mac users, hold down Command while dragging to simulate this
action.)

When zooming out, the smaller the box you drag, the further out you zoom.
Now let’s save.

12 Select Save from the File menu.

Rotating the Plinth
The plinth has got one of its edges facing us and what we really want is one of
the faces pointing towards us. We could move the camera, but it’s quicker to
rotate the plinth.

1 Ensure that the plinth (cube) is the selected object.

2 Ensure that the Edit Object button is selected.

3 Select Coordinates Manager from the Windows menu.

To see more of your scene in the 4T views,
drag a small box with the right mouse button.

Positioning objects by mouse is made easier if
you zoom on the area in question.

This section will take about
3 minutes to complete.

Note that the Managers are all on easy-to-
remember keyboard short-cuts.

The Move button.
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4 In the Coordinates Manager, change the value in the Direction H field (the
object’s heading) from 0 to 45 and press the Apply button.

The plinth rotates about its Y axis by 45 degrees and ends up facing towards the
camera. We used the Coordinates Manager to rotate the plinth simply to show
that there is more than one way to skin a cat... (er, better make that peel a
potato if you’re a vegetarian.)

If you prefer, you can rotate objects with the mouse using the same techniques
we are about to use to rotate the camera view.

You can close the Coordinates Manager window now if you like.

OK, so let’s adjust the camera position. We want to adjust it so that we are
looking at the scene from eye level rather than the “slightly up in the air” view
that we currently have.

5 Press the Edit Camera button.

6 Press the Rotate button.

7 Lock (switch off) the X axis and the Z axis, leaving the Y axis switched on
(unlocked).

8 Click in the 3D view and drag towards you until the grid lines that are
farthest away from you fall just below the shoulders of the plinth.

If you know exactly where you want your
object to be, the Coordinates Manager is very

often the best tool to use.

The Rotate button.

The Edit Camera button.
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And we’re done rotating. Well, for now at least. Next it’s about time we created
our floor and sky objects. Better save first, though...

9 Select Save from the File menu.

Sky and Floor
The Sky and the Floor are Special Objects. You can’t scale them, you can’t
move them... pretty much all you can do is give them a texture. (Well, actually,
something neat you could do in an animation is make the texture move over
the Sky or Floor object, but that’s another story for another day.)

1 Select Sky from the Objects>Special Objects menu and confirm the dialog.

Nothing apparently happens in the Scene Editor, but you’ll notice that an entry
for Sky has appeared in the Object Manager. The Sky is an object that totally
encloses our scenes like a big globe. Just as the real sky is all around the Earth
(that is, not just above us), so our scene’s sky is all around the scene. Later we
will put some clouds in our sky.

2 Select Floor from the Objects>Special Objects menu and confirm the
dialog.

Again, nothing apparently happens in the Scene Editor, but you’ll notice that
an entry for Floor has appeared in the Object Manager. The Floor is an object
that sits on the grid you can see in the 3D view and stretches to infinity in all
directions. Later we will lay some shiny linoleum on our floor.

Right, we have just one more object to create, the text that we’re going to
stand on the floor in front of the plinth. We’ll be spending a little time on this
Text object so now might be a good time to save what we’ve done so far and go
put the kettle on.

Placing the Text
Like Sky and Floor, Text is a Special Object. What we are going to do is place
some 2D text in the scene, then make CINEMA 4D create a 3D version of that
text using a technique known as “extruded splines”.

The word “splines” is just the technical term for the outlines of an object.
Extruding is a term borrowed from the manufacturing industry—it’s the process

Although we have placed Sky and Floor
objects in our scene, nothing appears to have
changed. Rest assured the sky and floor are

there, as you can see in the Object Manager.

This section will take about
2 minutes to complete.

This section will take about
4 minutes to complete.



20 CINEMA 4D QUICKSTART

used to create plastic and metal mouldings by forcing the material out under
pressure from a shaped die. So our 2D object is the die that CINEMA 4D will
use to produce the moulding—the 3D object, that is.

1 Select Text from the Objects>Special Objects menu.

2 Type some text into the dialog that appears (we have used the text “MYSTIC
PEG”) and press OK.

Our text will appear in the scene, flat as a pancake. It’s also running right
through the plinth, but don’t worry about that because we’ll be throwing away
this text object in a while. Now let’s get CINEMA 4D to extrude the splines of
the text.

3 Select Spline Objects>Extrude Object from the Object menu.

4 In the dialog that appears, go to the Cover Surfaces page and select Close
and Round for both the Front and the Back of the text, and then press OK.

Two-dimensional text can be added to your
scenes as easily as this.

To turn 2D text into 3D text, the text object
has to be “extruded”.
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After a very short delay while CINEMA 4D does its sums, a new object appears
in our scene—a 3D version of the text.

If you look in the Object Manager you’ll see that an Extruded Object entry has
been added above the Text Object entry. We don’t need the Text Object any
longer, so let’s get rid of it.

5 Click on the Text Object name in the Object Manager to select the object.

6 Select Delete from the Edit menu. (Or simply press the Del key on your
keyboard.)

And while we’re tidying up, let’s move that Extruded Object down the list and
give it a more sensible name.

7 Click on the Extruded Object name in the Object Manager.

8 Drag towards you until the mouse pointer is below Sphere in the list, then
let go of the mouse button.

The Extruded Object entry will move to the foot of the list. We could just as
easily have dropped the Extruded Object anywhere else in the list. Give it a try.

Always keep your scenes uncluttered by
deleting objects that are no longer needed.
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Where an object is in the list isn’t important to the scene, but often when you
have many objects in a scene you may want to structure your object list in a
logical manner—drag-and-drop is how you do it.

9 Select Rename from the Function menu. (Or simply double-click on the
Extruded Object name in the Object Manager.)

10 Give the object a new name (we called ours “Mystic Peg”) and press OK.

Positioning the Text
To position the text we can use the techniques we learnt earlier when positioning
the sphere and cube.

1 Ensure that the text is the selected object (click on its name in the Object
Manager).

2 Click on the Edit Object button.

3 Click on the Move button.

4 Ensure that the X, Y and Z axis buttons are switched on.

5 Click in the side view of the Scene Editor (bottom left) and drag the mouse
away from you until the base of the text is sitting on the Z axis.

6 Open the Coordinates Manager and change the H field under Direction to
45 and press Apply.

7 Click in the from-above view (top right) and drag the object down and to
the right a bit until the text is slightly in front of the plinth.

As you perform these operations you will see the text moving around in all four
quadrants of the Scene Editor. It is possible that when you have positioned the
text in front of the plinth that you cannot see its full width in the 3D view. If you
do not want to move the camera further away (so all the text comes into view)
you can scale the text so that it becomes narrower and/or shorter.

8 In the Coordinates Manager, under the Rel. Scale heading, alter the X field
to be 0.5 and press Return. (Pressing the Return key has the same effect as
pressing the Apply button.)

This section will take about
8 minutes to complete.

The easy way to alter the direction an object
is facing is to change its Heading in the

Coordinates Manager.
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The text will become half the width it was—that is 0.5 times as big. Notice that
the X field has gone back to a value of 1. That’s because we are altering the
relative scale, and an object is always its size times 1—it’s full size is always the
size it currently is, in other words. To change back to the previous width we
would have to enter 2 into the X field to make the text twice as wide as it
currently is.

Play around with the Rel. Scale X and Y fields until you are happy with the size
of your text. (You did save before you started playing, didn’t you?)

OK, that’s it, all our objects are in place. Now comes the fun part, covering our
objects with materials and textures so that they look more realistic.
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2. APPLYING MATERIALS
Applying a material to an object is like putting a tight-fitting cover on a sofa.
The difference is that in CINEMA 4D you can change the appearance of the
material without changing covers. To start with the material is plain. The simplest
thing you can do to a material is give it a colour, but by selecting various options
and applying textures you can make materials look like any material you want—
wood, metal, leather, plastic, glass, water, smoke... literally anything!

The Sky
We’ll start with the sky object. What we want is a blue sky with some fluffy
white clouds floating in it.

1 Open the Material Manager (from the Windows menu) if it isn’t already
open.

2 Click in the Material Manager and select New Material from the File menu.

A button (named New) with a shaded white sphere on it appears in the Material
Manager. As we adjust the material, the appearance of the sphere will change
to give us a rough idea of what the material looks like.

3 Double-click on the New material to open the Edit Material dialog.

The Edit Material dialog has quite a few pages. Currently we are looking at the
Colour page. We will be visiting most of the other pages as we make and apply
materials to our various objects.

4 Click on the File button and use the file selector to find and open a picture
named “Clouds.tif” in the “Tex” folder.

A thumbnail of the picture appears to the right of the filename. We are going to
“paint” this picture all over the Sky object.

5 Under the Colour heading, change the S value to be zero, then click OK.

The R, G, B and S sliders are used to give the material a colour. We don’t want
our material to have a colour (because the picture we have opened uses the
correct colours for a sky) so we have set the strength of the material to zero,

Materials are represented in the Material
Manager by a shaded sphere. The

appearance of the sphere will change to
reflect the properties of the material.

This section will take about
9 minutes to complete.
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which means no colour. If we hadn’t opened a picture then the material would
appear black—black being what we see when there is an absence of colour—
but as we have opened a picture then what we see is the picture.

Now then. The picture we have opened is only small and the Sky is big, way
bigger than the picture. And, of course, the picture is flat and rectangular whereas
the Sky is curved. How does CINEMA 4D completely fill a big round hole with
one little square peg?

Tiling is the answer. CINEMA 4D uses the picture over and over again, distorting
it where necessary, until it has covered the entire object. The important point
here is that where CINEMA 4D has joined the tiles, seams may show if the
picture isn’t designed to tile seamlessly (the “Clouds.tif” picture is).

6 Click on the New material, select Rename from the Function menu and
give this material a sensible name (like Sky, for instance).

7 Position the mouse pointer over the newly-named Sky material, hold down
the (left) mouse button, drag the pointer over the Sky entry in the Object
Manager, then let go of the mouse button.

We have just used the drag-and-drop technique to apply the material to the
object. Alternatively, if we felt like doing it the long way, we could have clicked
on the object name in the Object Manager, clicked on the material in the
Material Manager, and then selected Apply from the Function menu.

Always give your materials sensible names.

In the Object Manager materials are
represented by an icon of a sphere with a

little square of colour on it.
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Right, hold on to your horses and don’t get too excited here because it won’t
be anything to write home about, but we are going to render the scene.

8 Click in the Scene Editor and press the Render in External Window button.

The scene will start to render and you will see the blue of the sky. Not very
good, is it? Doesn’t look much like a cloudy sky to us. There’s a reason for that,
and we can fix it.

9 In the Object Manager, to the right of the Sky entry, double-click on the
icon that represents the material—the one that looks like a dark circle with
a little blue square in the centre of it.

The Texture dialog that appears contains some fairly advanced features and
this Quickstart book is not the right place to describe them, so we’ll concentrate
on just the two settings that we need to adjust in order to put the clouds back
into our sky.

Double-click on this type of icon in the
Object Manager to edit a texture.

The Render to External Window button.



30 CINEMA 4D QUICKSTART

To understand what we are going to do you need to understand what CINEMA
4D has done with the picture we’ve used as a texture for the sky. Right now,
CINEMA 4D is doing its level best to tile the sky using as few “copies” of our
picture as possible by stretching it out. So the clouds in our picture are actually
there, washed out a bit by the stretching process, and by the looks of it mostly
in another part of the sky.

Now then, because we can put lots of copies of this particular picture together
like a jigsaw and not see the joins, we can ask CINEMA 4D to use lots of copies
instead of stretching out a single picture. We do this by specifying how much of
the sky should be covered by one copy of the picture.

10 In the Texture dialog that we have open, change the values in the X and Y
Length fields from 100 to 20, then press OK.

We have told CINEMA 4D to cover only 20 per cent of the sky with one picture
instead of 100 per cent of the sky with one picture. Let’s render it again so we
can see the difference.

11 Click in the Scene Editor and press the Render in External Window button.

There we go, that looks more like a sky. If you change the percentages to 10 or
5 the sky will become even cloudier, but although you won’t be able to see any
joins you will begin to see a regular pattern of clouds, and that would destroy
the illusion. Try it!
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When you are using tiled pictures for textures, keep a weather eye out for this
type of regular pattern; one way to destroy the pattern is to enlarge those X and
Y Length percentages.

OK, that’s it for the sky. Time to save and move on to the floor.

The Floor
For the floor we are again going to use a picture as a texture, but we are going
to give the floor some properties so that it looks like shiny linoleum. The first
few steps of this process are the same as they were for the sky.

1 Open the Material Manager if it isn’t already open.

2 Click in the Material Manager and select New Material from the File menu.

3 Double-click on the New material to open the Edit Material dialog.

4 Click on the File button and use the file selector to find and open a picture
named “Check.tif” in the “Tex” folder.

This section will take about
6 minutes to complete.
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The checks are black and white. We don’t like black and white checks, but we
do like blue and white checks.

5 Under the Colour heading, change the R and G values to 0, leaving the B
and S values at 100. (Don’t close the dialog yet.)

Notice that the material thumbnail in the top right of the dialog now shows the
texture to have blue and white checks. Right, lino is shiny—it reflects things in
other words—so let’s make it shiny.

6 Go to the Reflection page.

The settings on this page all have an effect on how a material should reflect
light. But only if reflections are turned on...

7 Click in the little white box to the left of the Refl. option so that a tick
appears.

We have now switched on reflections for this material and we can see the
effect this has had on the material thumbnail. Much too shiny, let’s tone it
down a bit.

8 On the Reflection page, adjust the strength of the colour (the S slider under
R, G and B) from 100 to 30.

Better. That’s the floor finished. All we have to do now is give the material a
sensible name and apply it to the Floor object.
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9 Click OK in the Edit Material dialog and then select Rename from the
Function menu. Give the material a sensible name (like Floor for instance).

10 Apply the floor material to the Floor object by dragging the material’s icon
on to the Floor object in the Object Manager.

Go on, we know you’re busting for it... have a quick render to see what the
scene looks like now. But save first!

The Plinth
Let’s make the plinth have a black plasticky kind of PVC type texture.

1 Open the Material Manager if it isn’t already open.

2 Click in the Material Manager and select New Material from the File menu.

3 Double-click on the New material to open the Edit Material dialog.

4 In the Colour page, set the strength of the colour to zero.

5 Go to the Bump page.

This time, instead of using a picture to give our material a texture we are going
to use something called a bump map—so named because it gives a material a
bumpy kind of texture.

This section will take about
4 minutes to complete.
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A bump map is actually a picture, but instead of the actual picture being used
for the texture the shade differences in the picture are used in combination
with the other settings for the material. For this reason bump maps are normally
created in shades of grey, but any shade of any colour can be used, or even a
normal colour picture.

For bump maps to work we first have to switch on that feature for the current
material.

6 Click in the little white box to the left of the Bump option so that a tick
appears.

7 Press the File button and use the file selector to find and open the bump
map named “Bump13.tif” in the “Tex” folder.

8 Adjust the Strength setting to read 20%.

The appearance of the texture in the material thumbnail hasn’t changed at all
yet. That’s because our material is not reflecting any light. We don’t want full
reflections on this material, all we want is highlights where the texture wobbles
up and down.
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9 Click in the little white box to the left of the High. option so that a tick
appears. (Note that we don’t have to go to a function’s page just to switch
on that function, only when we want to alter settings for that function.)

The material thumbnail now has some texture. Does that look like a black
plasticky kind of PVC type texture to you?

10 Click OK in the Edit Material dialog, give the material a sensible name (like
Plinth for instance), and apply it to the Cube object.

So much for the plinth. Next we come to the... tch, go on then, have a quick
render to see what it looks like. But do save first!

Didn’t look particularly good, did it? Don’t fret, all will become clear soon.

The Crystal Ball
A crystal ball is, quite naturally, made of crystal, so that’s the type material we
have to create for it. It’s actually very easy to create a glass or crystal material
because CINEMA 4D does all the hard work for us.

1 Open the Material Manager if it isn’t already open.

2 Click in the Material Manager and select New Material from the File menu.

3 Double-click on the New material to open the Edit Material dialog.

4 In the Colour page, set the strength of the colour to zero.

Our scene is beginning to take shape.

This section will take about
3 minutes to complete.
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Remember, a colour strength of zero means “colourless” not “black”. The
material will appear black unless we do other things to it, but that’s because it
lacks colour, not because it has been “painted” black.

Now we need to turn our colourless ball into a crystal one.

5 Go to the Transparency page.

6 Click in the little white box to the left of the Trans. option so that a tick
appears.

The material is now transparent. In fact it is so transparent that we can’t see it.
That’s easily fixed.

7 Still on the Transparency page, adjust the the strength of the colour to 70.

Now the texture shows up in the material thumbnail as light grey. Crystal balls
are highly reflective and will have highlight spots when lights are shone on
them, so let’s turn on those options.
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8 Go to the Reflection page.

9 Click in the little white box to the left of the Refl. option so that a tick
appears.

10 Adjust the strength of the colour to 25 to tone down the reflections.

11 Click in the little white box to the left of the High. option so that a tick
appears.

The material thumbnail now looks very much like a crystal ball. We may need
to tweak it later, then again we may not... For the moment let’s settle for what
we’ve got.

12 Click OK in the Edit Material dialog, give the material a sensible name (like
Crystal for instance), and apply it to the Sphere object.

If you render the scene now you’ll be fairly pleased with the results, but it’s far
from perfect. Perfection will come later, but first we must give a material to our
final object, the text in front of the plinth.

Don’t forget to save before starting on the next stage.

Now we can see into our crystal ball.



38 CINEMA 4D QUICKSTART

The Text
For the crystal ball we created our own material from scratch, without the help
of pictures or bump maps. We are going to do the same thing for the text to try
to give it a shiny gold metallic appearance.

1 Open the Material Manager if it isn’t already open.

2 Click in the Material Manager and select New Material from the File menu.

3 Double-click on the New material to open the Edit Material dialog.

4 In the Colour page, set R to 100, G to 90, B to zero and S to 75.

That’s our basic gold colour. Now, the thing about gold, so people say, is that it
kind of glows on you. It doesn’t actually glow, but people are always saying
how gold seems to have its own light almost as if in a pitch black room you
would still be able to see gold. We can do that.

This section will take about
5 minutes to complete.
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5 Go to the Luminance page.

6 Click in the little white box to the left of the Lumin. option so that a tick
appears.

7 Set the R value to 10, G to 10, B to 0 and leave S on 100.

We have now set up the material so that even in a pitch black room with
absolutely no light anywhere, we will still be able to see it as this very dark olive
green kind of colour.

Don’t think of luminance as a light. It isn’t. Although the material is luminous, it
is emitting no light so it will not illuminate the scene in any way. The material is
luminous, not illuminant.

Lastly, to make the material appear metallic we need to make it shiny and give
it highlights.

8 Go to the Reflection page.

9 Click in the little white box to the left of the Refl. option so that a tick
appears.

10 Set the R value to 75, G to 30, B to 30 and S to 50.
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What we have done here is limit the colours that get reflected. Think of a silver
mirror. If you look in that mirror in normal daylight you’ll see yourself reflected
in that mirror pretty much as you look in real life. If you have a red nose, your
reflected nose will be red.

Now look in a gold plated mirror. Will your nose still be red. No, it won’t, it’ll
be a “goldy-red” colour. The gold doesn’t reflect the entire spectrum of colours,
which is why it looks gold to us and not silver, or pink, or tartan or whatever.

So we have set the sliders to reflect the maximum amount of each colour that
can be reflected. One way of visualising this is to think of the entire spectrum
being reflected, but only up to the level each slider is set to.

Setting our maximums to this murky red colour is ultimately what will give our
material a realistic gold appearance.

But it won’t look right without highlights...

11 Go to the Highlight page.

12 Click in the little white box to the left of the High. option so that a tick
appears.



41CINEMA 4D QUICKSTART

13 Leave the Mode as Plastic (in this case we think it just happens to look
better than the Metal mode), but change the Width setting to 15 so that
the highlights aren’t too big, more like sparkles.

14 Click OK in the Edit Material dialog, give the material a sensible name (like
Gold for instance), and apply it to the Mystic Peg object (or whatever else
you called the text).

And we’re all done with materials. Don’t bother rendering the scene because
we’ll be doing that in a minute anyway. Save your work and let’s take a break.
When we come back we’re going to spend some time seeing the light.
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3. LIGHTING THE SCENE

If you haven’t already rendered the scene, do it now... Like it? It’s a fairly pleasing
scene, but the lighting’s all wrong. The only light at the moment is that being
provided by a light that CINEMA 4D automatically places behind the camera—
you can think of it as an auto-flash, and, like a real auto-flash, if we light the
scene ourselves the auto-flash won’t flash. So let’s light the scene.

We’ll start with some ambient light—a general light source that will emit light in
all directions—and we’ll position it up in the air above the crystal ball.

1 Select Light from the Objects>Special Objects menu.

2 Rename the object to Ambient Light.

Let’s give our ambient light some character rather than have it a bland and
unnatural white.

3 Set the R value to 100, G to 60, B to 50 and S to 100.
Light is a Special Object in the Object menu.

This section will take about
4 minutes to complete.
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And let’s reduce its strength a little by forcing the light to decrease gradually
over a distance. This ought to add some shading to our floor.

4 Click in the little white box to the left of the Decrease option so that a tick
appears.

5 Press the OK button.

The Ambient Light object appears in the Object Manager and in the scene we
can see it at the intersection of the X, Y and Z axes. It’s not a lot of good to us
there, so let’s move it.

6 Ensure that the Move button is selected.

7 Ensure that the Edit Object button is selected.

8 Ensure that Ambient Light is the selected object.

9 Open the Coordinates Manager if it isn’t already open.

Lights can have many properties. For this
scene we are starting with a simple, soft red
light whose strength decreases with distance.
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10 Click in the side or front view and drag the Ambient Light up until the Y
Position coordinate in the Coordinates Manager is about 500.

Remember, you can lock off the X and Z axes to stop the object wandering off
in the wrong direction, or simply reset the X and Z Position coordinates to zero
in the Coordinates Manager.

11 Press the Render in External Window button.

What a difference, eh? And it’s going to get a lot better still.

More Light
The scene is well lit now, but the text looks a bit drab. How about if we stick a
spotlight on it?

1 Select Light from the Objects>Special Objects menu.

2 Rename the object to Spotlight.

3 Ensure that the R and G colour sliders are set to 100, then set the B colour
slider to zero so that the spotlight is bright yellow.

4 Turn on the Spot option (click the white box to the left of it).

The default Spot Angle is a bit narrow for our purposes, so let’s widen it.

5 Set the Spot Angle value to 45 and press OK.

The Spotlight object appears in the Object Manager, and in the Scene Editor
you can see the Spotlight as lines radiating from the intersection of the X, Y and
Z axes. Now we have to move it and point it at the text.

BEFORE
LIGHTING

AFTER
LIGHTING

This section will take about
4 minutes to complete.

To create beams of light that widen from a
narrow point, you need to switch on the
Spot option and set the required Angle.
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6 Ensure the Move and Edit Object buttons are selected.

7 Switch off the X and Z axes (leaving the Y axis switched on), then drag the
Spotlight up (the Y axis) until it is at about the same height as the top of the
crystal ball.

8 Switch on the X axis, switch off the Y and Z axes, then drag the Spotlight off
to the right of the scene until its X Position coordinate in the Coordinates
Manager is at about 500.
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Good. So our Spotlight is in position. But it isn’t pointing at the text. We could
do this with the mouse (using the Rotate and Edit Object buttons) but only if
we really enjoy doing things the hard way. Which we don’t, so we’re going to
do it the easy way.

8 Ensure the Spotlight is the selected object, then select Align to Object
from the Tools menu.

If it helps, think of Align to Object as meaning Point at Object. You’ll use this
feature a lot with lights. The dialog that opens wants to know which object to
point the Spotlight at.

9 Type the letter “c”.

Below the text field CINEMA 4D will display the name “Cube”, which is our
plinth of course. The text is directly in front of the plinth and if we point the
spotlight at the plinth (cube), the text should fall within its beam as well. This
way we get to spotlight the plinth and the text with just the one light.

10 Press OK.

CINEMA 4D will grab hold of the spotlight and point it at the Cube object. And
that’s it, the scene is finished. Now we can render it properly.

The easy way to make any object point at
any other object is to select the first object

and then pick this menu option.

As you type into a Search For text box,
CINEMA 4D will save you time by trying to

complete the name for you.
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4. RENDERING
At the moment, all of the fancy rendering functions are turned off. There’s no
shadows, no anti-aliasing and the picture is being rendered in a fast, lower
quality mode known as “scanline” rendering. We’ll adjust the render settings
in a moment, but before that let’s do a quick render to see what we’ve got.

1 Press the Render to External Window button.

If you study the output closely you’ll notice that most of the curves and diagonals
are a bit jagged. And there are a few things about the picture that don’t seem
quite right: the lino isn’t shiny, there aren’t any shadows, the spherical crystal
ball isn’t refracting the light passing through it...

We can fix all this and more in the Render Settings dialog.

2 Select Render Settings from the File menu.

3 Set Render Mode to Raytracing.

This section will take about
5 minutes to complete
(not inc. rendering time).

Before you render, always check that the
Render Settings are set appropriately.
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Raytracing is the highest quality rendering mode. We used scanline rendering
while developing the scene because it renders much more quickly.

4 Set Antialiasing to Always.

5 Set Oversampling to 3x3.

Antialiasing will get rid of those jagged diagonals and curves. We’ve set it so
that anything CINEMA 4D decides needs antialiasing will get antialiased. In
particular, antialiasing will cause tiny floor tiles in the distance to blur together,
which is how they would appear in reality.

The higher the level of oversampling, the more of the surrounding pixels are
taken into account when CINEMA 4D is deciding whether to antialias a pixel
or not. A setting of 2x2 or 3x3 is normally sufficient. Keep in mind that each
level of oversampling will cause the render to take twice as long as the previous
level.

6 Set Transparency to Full Refraction.

Setting this option will ensure that light is refracted (bent) correctly when it
passes through transparent objects. This will dramatically improve the
appearance of our crystal ball.

7 Set Reflections to All Objects.

The default setting (Floor & Sky) means that only the floor and sky objects will
be reflected in any material that has reflections switched on. That’s why our
lino wasn’t shiny—all it has been reflecting is the sky. Now it will reflect the text
and the crystal ball and will make a massive difference to our picture.

8 Set Shadows to Soft and Hard.

No shadows were being cast in our earlier renders. Setting this option will give
everything a better appearance of depth.

9 Go to the Output page.

10 Set Colours to 24 Bit.

11 Set Resolution to 800 x 600.

The General render settings are where you
decide the quality of the output.
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12 Press the File button and then select a folder and give your picture a filename.

Giving your picture an output path and filename will cause it to be saved to
disk automatically after it has rendered. If you don’t provide a path and filename,
when the picture has rendered you can save it by selecting Save Picture As
from the File menu. The picture will save in whatever file format was set in the
Output page of the Render Settings dialog.

All Done
We hope you have enjoyed your first tour of CINEMA 4D. We covered a lot of
ground creating our simple scene and you now know enough to be able to
follow the animation tutorials with confidence. And that’s when the real fun
starts...

The Output render settings page is where
you decide the output format of the frame or

frames to be rendered.
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5. ANIMATION
Having used many 3D features to create a static scene, now we are going to
use many of the 4D features to bring that scene to life.

As with the scene tutorial, the aim here is not to show you every single feature
of CINEMA 4D, but rather to introduce you gently to the basic animation features
so that you have a solid foundation on which to build.

This is the plan.

First we are going to learn about a simple animation technique called “key
frame animation” by making the text fly off and come back again, while at the
same time spinning through 360 degrees.

Second we’ll learn about a slightly more advanced technique called “time line
animation” by making the individual letters of the text rotate and tumble while
the whole text is flying and spinning.

Third we’ll learn about animation paths, the technique we must use if we want
to have total control over how each and every object in the scene moves or
changes over time. In this final part of the animation tutorial we will introduce
a glowing light into the scene that changes colour while floating around the
scene, and then we’ll “pick up” the camera and zoom right in on the crystal
ball.

Key Frame Animation
Keyframe animation is the simplest form of animation within CINEMA 4D and
it involves just three steps. First we take a snapshot of an object at one point in
time, then we take a snapshot of the same object at another point in time. If
between the two snapshots (known as key frames) the object has moved,
changed colour, grown, shrunk or has been altered in any way, CINEMA 4D
will perform the third step in the process—it will create an animation that
transforms the object from the first key frame to the last key frame.

Using the scene created in the previous section, for our key frame animation
we are going to animate the text so that it moves towards the camera while
rotating through 360 degrees.

This section will take about
20 minutes to complete
(not inc. rendering time).
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1 Open the Crystal Ball scene and select the 4T view.

2 Open the Object Manager if it isn’t already open and click on the name of
the extruded text object (that we named “Mystic Peg” and you might have
named something else), and then ensure that the Edit Object button is
selected.

Now we must set the key frames that CINEMA 4D will use to build the animation.
We do this in the Time Manager.

3 Open the Time Manager from the Windows menu.

This window contains a slider and some VCR style buttons. The slider represents
a point in time in an animation, represented as a time in seconds or as a frame
number. Note that a frame that is at 2 seconds on the slider would also be the
30th frame of an animation that has a frame rate of 15 frames per second (fps).

The buttons are used just like a VCR—they enable us to navigate through the
animation and its key frames.

The Time Manager is where you record the
key frames of your animation.
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3 Set the slider to frame zero if it is not already there. Ensure that the Position
and Angle options are selected.

4 Press the Record button.

This has recorded a key frame for the text at time zero. The key frame will
include data for the object’s position in the 3D world as well as the angle at
which the object is pointing.

5 Ensure that the fps field is set to 15 frames per second, then drag the slider
to the right until it reads 40.

6 Open the Coordinates Manager. Ensure that World Coordinates is switched
off, then add +360 to whatever value is currently in the H field under
Direction.

CINEMA 4D allows us to enter formulae into value boxes. So entering +360
next to the H value will cause 360 degrees to be added to the current heading
of the selected object.

7 Select Apply (or press Return).

The 360 now gets added to whatever value was in the H box.

8 In the Time Manager, press the Record button.

It appears as though nothing has happened. Ah, but it has. Drag the Time
Manager slider between 0 and 40. See?

Getting CINEMA 4D to rotate our text through 360 degrees is that easy. But
you’ve probably already spotted the problem. As the text rotates, it splats right
through the plinth. We need to move the text away from the plinth.

9 In the Time Manager, drag the slider to the 25 position.

10 Using the mouse, drag the text up and away from the plinth until the Z
Position value in the Coordinates Manager is at about -500. You will probably
find that it is easiest to perform this action in the side view (bottom left).

We move the slider to frame 40 ready to
record that frame as a key frame after we

have made the changes.

Now we must move the text because it is
passing straight through the plinth.

The animation needs to start somewhere, so
we record frame zero as our first key frame.

CINEMA 4D makes life easy by allowing us to
enter sums into value boxes.
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As we move the text, in the 3D view we can see that the text grows larger as it
approaches the camera and shrinks as it moves away from the camera.

11 Once the text is no longer cutting into any part of the plinth or crystal ball,
press the Record button in the Time Manager.

Pressing the Record button has taken a snapshot of the current frame of the
scene (a key frame) just as we have set it up. CINEMA 4D will work out what
has to be moved or changed from the previous key frame to get the scene to
look like this. If we don’t press the Record button, the snapshot will not be
taken. Forgetting to press the Record button is a common mistake that many
novice animators make.

OK, if we now review the animation (by pressing the Play button in the Time
Manager) we can see that the text still collides with the plinth at around frame
6 or 7. To fix this we will have to go to the frame just before the text collides
with the plinth, move the text away from the plinth, then add that frame as
another key frame.

12 In the Time Manager, move the slider to frame 5.

The text is still colliding with the plinth at
about frame 7, so we must go to an earlier

frame and move the text further away.
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13 Using the mouse, move the text up and away from the plinth. When the
text is in a suitable position, press the Record button in the Time Manager.

We have almost finished our first animation. To complete it we have to render
it as a movie. On the PC this will be as an AVI file, on the Mac it will be as a
Quicktime Movie file.

14 Select Render Settings from the File menu and set the General settings to
the same as those used in the scene tutorial.

15 Select the Output page.

16 Set Resolution to 320x240.

17 Set Colours to 24 Bit.

18 Set Format to AVI Medium (PC) or Movie Normal (Mac).

19 Set Frames to Manual and change the field on the far right from 75 to 40.

When rendering animations, always check
that the Frames setting is set correctly.

For a much quicker (but lower quality)
render, set Antialiasing to None.
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20 Press the File button, select a folder and filename for the movie file, then
press OK.

21 Press the Render in External Window button.

A new window will open in which our frames will be rendered one by one, and
our complete animation will be saved to the file named in the Render Settings
dialog.

To play the animation, double-click on the finished movie file and your default
movie viewer will play it for you. (On the PC this will normally be Media Player,
on the Mac it is usually Movie Player.)

In the next section we are going to use the Time Line window to animate the
individual letters of the text.
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Time Line Animation
Keyframe animation is ideal for producing an animation that uses only a few
simple transformations. For more complex and professional effects we need to
use the time line—a visual representation of when an action starts and stops.

There are three terms we must become familiar with before using the Time
Line window in anger, these are tracks, sequences and key frames.

1 Open the Crystal Ball animation.

2 Select Time Line from the Windows menu.

In the Time Line window you will notice that there are two entries labelled
Position and Direction. These are tracks that CINEMA 4D created automatically
for what we animated in the previous tutorial. The lines running off to the right
of the track names are called sequences. Along the sequences there are some
little markers. These represent the key frames (a term often shortened to just
“keys”) that again CINEMA 4D created automatically for the previous animation.

If we double-click on a key or a sequence, a settings window for that key or
sequence opens. Double-clicking on a position key opens a window showing
the X, Y and Z coordinates of the object at that key frame, double-clicking a
direction key opens a similar window but this time showing the heading, pitch
and bank (HPB) of the object at that key frame. A double-click on a sequence
body opens a window that enables us to set the start and end time of that
sequence.

Notice that the sequence has a “tail” that extends beyond frame 40, the last
frame of our previous animation. This is for no other reason than because the
default animation length happens to be 75. If the tail of a sequence bothers or
confuses you, simply select that sequence (click on it so that it turns red) and

This section will take about
15 minutes to complete
(not inc. rendering time).

The Time Line provides a record of every
action performed in an animation, and allows

us to edit those actions.
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select Adjust from the Function menu. This will shorten the sequence so that it
ends at the last key frame on that sequence.

OK, we are now ready to start animating the individual letters.

3 In the Time Line window, click on the little symbol to the left of the name
of our text object.

This symbol tells us that the object is actually a group of objects. Clicking the
symbol opens a list of all the sub-objects for an object. (The same system is
used in the Object Manager.) The main object is known as the parent object,
the sub-objects are known as the children of that parent object.

4 Click on the first sub-object of our text (which will be G if, like us, you used
“MYSTIC PEG” as your text).
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It will turn red and all other object names in the list will be displayed in black.

5 Go to the File menu and select Direction from the New Sequence sub-
menu.

6 In the Sequence Edit window that appears, enter 0 into the From field and
40 into the To field, then press OK.

We have created a new direction sequence, starting at frame 0 and ending at
frame 40. Now we need to add some key frames to the sequence.

7 Hold down the Ctrl key and click right at the start of the direction sequence
we have just created. A Direction window opens that enables us to add a
key frame for the direction. Simply press OK.

8 Hold down the Ctrl key and click right at the end of the new direction
sequence. The Direction window appears again, this time enter 360 into
the H (heading) field.

The two key frames we have just set will cause the letter to spin 360 degrees
about its Y axis. This action will be completely independent of the parent object’s
sequences.

To animate a letter we have to first select it in
the time line and then start a new sequence

for the animation to run along.
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9 Go through steps 4 to 8 again to add a new direction sequence to the next
sub-object (E in our example), add a new start key, and an end key that has
360 entered into the P (pitch) field.

10 Go through steps 4 to 8 again to add a new direction sequence to the next
sub-object (P in our example), add a new start key, and an end key that has
360 entered into the B (bank) field.

Hmm. All this adding of new keys is getting rather tedious. There must be an
easier way. Indeed there is. CINEMA 4D allows us to drag-and-drop copies of
sequences.

11 Hold down the Ctrl key and drag the first sequence we created (for G) until
it is over the first blank sub-object (the C of “MYSTIC”), then let go of the
mouse button to drop a copy of the sequence there.

If the left edge of the copy isn’t lined up with the sequences above it, simply
drag the sequence to the left until it lines up. If you click on and drag the
Direction track label (rather than the sequence line itself), then the alignment
of the original sequence will be duplicated and you won’t have to fiddle around
with the copy after dropping it.
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Because we were holding down the Ctrl key, we have dragged a copy of the
sequence and key frame data. If we hadn’t been holding down the Ctrl key
then we would have moved the sequence rather than copied it.

12 Using the same drag-and-drop technique (holding down the Ctrl key,
remember), take the second sequence we created (for E) and drag it on to
the next blank sub-object track (I in our example), aligning after dropping
if required.

13 Using the same drag-and-drop technique, add direction sequences to all
the remaining sub-objects.

OK, let’s have a quick look at what we have done.

14 Click in the Scene Editor and select Time Manager from the Windows menu,
then press the Play button to view the animation in the Scene Editor.

The text is now taking off, as it was before, but now the individual letters are
spinning as well. Looks good to us, let’s raytrace it!

15 Using the same settings as we used for the previous animation, render this
new animation (but give it a new filename if you want to keep a copy of
the old animation).
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So far we’ve looked at two animation techniques, and both ask CINEMA 4D to
work out for itself how to move objects from A to B. This is fine for simple work,
but there will come a time when we know exactly how we want an object to
move from one point to another. To do this we need to lay down paths for
objects to follow. And that’s just what we’re going to do next.

Animation Paths
If we are building a complex animation that has lots of objects moving at the
same time, we are going to have a problem remembering where to set key
frames. To help with this, CINEMA 4D allows us to define a path which we can
tell an object to follow. The technical term for this path is a “spline path”.

A spline path is nothing more than a line defined by a series of dots—imagine
a 3D join-the-dots puzzle. CINEMA 4D includes a selection of predefined
splines, such as circles and squares, but when you become experienced you
will be able to draw any shaped spline path you like. To start with, let’s animate
an object along a predefined spline path.

This section will take about
10 minutes to complete
(not inc. rendering time).
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1 Open the Crystal Ball scene from the last section.

2 Select Splines>Helix from the Objects menu.

3 In the Helix settings window, enter *2 next to the value in the Extrusion
field and *2 next to the value in the Rotation field, then press OK.

CINEMA 4D allows us to enter formulae into value boxes. So entering *2 next
to the Extrusion and Rotation values will cause the default values of 200 and
360 to be doubled to 400 and 720.

4 Add a new light source to the scene (Objects>Special Objects>Light) and
rename it to Ball of Light.

Our first step in animating an object will
normally be to create a “spline path” for the

object to travel along.
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5 In the Light settings dialog for the Ball of Light, adjust the colour sliders so
that R is 100, G is zero, B is zero and S is 100.

6 Select XYZ Decreasing from the Visible Light pop-up menu, set X, Y and Z
Radius settings all to 100, then press OK.

7 Open the Time Line window, ensure Ball of Light is the selected object,
and select New Sequence>Spline from the File menu. Create a spline
sequence for the Ball of Light that starts at frame 41 and ends at frame
110.

8 Add a new key on the spline sequence (click with Ctrl held down) at frame
41. A box will appear asking for the name of a spline.

9 Start typing “helix” and before you even get to typing the “e” you will see
that the word “Helix” appears below the entry field. This is CINEMA 4D
completing the name for us. Press OK.

If we now return to the Scene Editor and review the animation by moving the
Time Manger’s slider, we will see the ball of light wind around the crystal ball as
it follows the path of the helix.

10 Open the Render Settings dialog and using the same settings as we used
for the previous animation (ensure that the Frames option is set to All
Frames), render our new animation. (Give it a new filename if you want to
keep a copy of the old animation).

If we want to move an object along a path,
first we must create a spline sequence for

that object.
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Recall that we have added 70 frames to the animation so it is going to take
about three times as long to render as either of our previous animations.

For our final two tutorials we are going to use some more advanced features to
add spit and polish to our animation. First we are going to fade the ball of light
into the scene so that it doesn’t just appear out of the blue, then we are going
to zoom the camera into the crystal ball and fade the whole scene out to white.

Animating Lights
If you’ve played the animation rendered at the end of the previous section you
will have noticed that the red ball of light suddenly appears at the base of the
plinth and then starts moving up the spline path. This is not a particularly elegant
way of introducing the ball of light to the scene. What this section will deal with
is animating the ball of light so that it fades into the scene, then changes colour
as it travels along the spline path.

This section will take about
2 minutes to complete
(not inc. rendering time).
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1 Open the Time Line window, ensure that Ball of Light is the selected object,
and select New Sequence>Parameter from the File menu. Create a
parameter sequence between frames 41 and 110 for the Ball of Light.

2 Hold down Ctrl and click the left-hand end of the new parameter sequence
(labelled Light in the list) to add a key frame there. The Light dialog will
open. Leave the RGB values alone but set the strength of the colour (S) to
zero and set the Visible Light Brightness to 0%. Press OK.

What we’ve done here is stop the light emitting any rays. In effect, we’ve turned
off the light. Now we’ve got to set a key frame where the light is full on.

We are going to change the parameter
settings (colour and strength) for the ball of
light, so we must first create a parameter

sequence for it.
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3 Hold down Ctrl and click the Light sequence at around the frame 70 mark.
Leave the RGB values alone, ensure the strength of the colour is set to 100
and Visual Light Brightness is set to 100%. Press OK.

Hmm. Have we set the key frame at the correct point? Sure, it looks like frame
70-ish, but we want it to be exactly frame 70.
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4 Click on the key frame we’ve just created and select Edit Time from the
Function menu. The frame number of this key frame is in the entry field. If
it isn’t 70, make it 70 and press OK.

CINEMA 4D will automatically fade in the ball of light from nothing to full
brightness over 30 frames (two seconds). Now we want it to change colour.

5 Add another key at the end of the Light sequence, and this time set R to
100, G to 100, B to 0, S to 100 and Visible Light Brightness to 100%.
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If we now play the animation from the Time Manager, the Scene Editor will
show the light change in colour as it goes from black (off) to red (frame 70) and
then to yellow (frame 110).

Don’t render the scene again at this point because we have just two little finishing
touches to put to it.

Animating Textures
For the final scene of our animation we are going to make the camera move
from its current static position towards the crystal ball, and when it gets to the
point at which the crystal ball fills the camera view we are going to fade the
crystal ball to white (which in effect will fade the whole scene to white). Let’s
do the fade first.

1 Open the Material Manager, add a new material, rename it to White.

2 Double-click on the new White material to edit it.

3 Switch off the Colour option (no tick in the box).

4 Switch off the Trans. option.

5 Switch of the Refl. option.

6 Go to the Luminance page and switch on the Lumin. option. Set the R, G,
B and S values to 100.

So what have we been doing? The material we have created has a brilliant,
pure white luminance, but it has no colour, no transparency and is not reflective.
We are going to feed this material into the Time Line so that CINEMA 4D can
smoothly change the texture of the crystal ball from its current glass-like
appearance to this brilliant white.

6 Go to the Time Line window, ensure that Sphere is the selected object and
select New Sequence>Texture 1 from the File menu. Create a texture
sequence for the sphere (the crystal ball) that starts at frame 170 and ends
at frame 200.

We are creating a new White material so that
we can “animate” the Crystal material

gradually from one material to another.

This section will take about
2 minutes to complete
(not inc. rendering time).

We want to gradually change a texture, so we
first need to create a Texture sequence.
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7 Add a key at the start of the texture sequence (Ctrl-click) and leave this set
to Crystal.

8 Add a key at the end of the sequence and set the texture to White.

Animating a Camera
1 Open the Time manager if it isn’t already open and move the slider to

frame 110.

Since we are planning to move the camera, we need to add a camera object to
the scene so that we can set position sequences.

2 Go to the Scene Editor and select Objects>Special Objects>Camera. Ensure
Lens is set to Normal and Focal Length to None, then press OK.

The new camera object will be placed in the same location as the current
Scene Editor camera.

3 In the Action toolbar, select the bottom right button—Attach Editor Camera
to Active Object.

This section will take about
6 minutes to complete
(not inc. rendering time).

The Attach Editor Camera to Active Object
button.
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This button attaches the Scene Editor camera to the currently selected object.
Since the new camera object is the currently active object, the Scene Editor
view will switch to the view from the new camera object.

4 Press the Record button in the Time Manager and then move the slider in
the Time Manager to frame 170.

5 Ensure that the Edit Object button is selected and then lock the X axis
(leaving Z and Y unlocked).

6 In the Scene Editor, drag the camera object so that it almost touches the
crystal ball. (Ensure that it is the green-coloured camera you are moving,
not the red-coloured spline path for the camera.)

7 Press the Record button in the Time Manager.

Our animation is now complete. Well, OK, we haven’t rendered it yet, but
that’s all there is left to do.
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The Final Render
Now then. We’ve got 201 frames here with refractions and reflections all over
the place. Even at 320 by 240 pixels (VHS NTSC size) it is going to take quite a
while to raytrace. Exactly how long will depend on the speed of your computer.

With antialiasing and 3x3 oversampling, on the fastest professional Macintosh
it’ll take maybe two hours. On a fast home PC we’re looking at about nine
hours. On the slowest Power Mac it’ll take about two days.

If you are busting to view the animation as quickly as possible, then render it
with the settings we used before, but switch off antialiasing. The animation
won’t look quite as nice, the floor tiles in particular will have very jagged edges,
but the animation will render much more quickly—about four hours on the
slowest Power Mac; about one hour on a fast home PC; about 15 minutes on
the fastest professional Macintosh.

Also keep in mind that there is nothing to stop you rendering a high quality
version of the animation in lots of small stages, perhaps 10 or 20 frames at a
time, then using a suitable program to join the bits of the animation together.

Of course, we’re lucky, we bought CINEMA 4D. Had we bought some other
modeller/raytracer then we might have had to wait a week, two weeks, a month
or more for this animation to render on our home PC or Power Mac.
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A. WHAT NOW?
Having completed the scene and animation tutorials, you now have a solid
foundation on which to build. If you’re new to 3D modelling and animation,
the trick is not to be too ambitious to start with.

Begin by changing the tutorial scene and animation. How about making the
crystal ball lift off the plinth, fly about a bit, then land and roll off into the
distance? If you have followed along with the tutorials, you have the skills to do
this.

Change the materials, change the textures, change the colours... change
everything. You will learn more from this type of experimentation than by
attempting to create a scene or animation from scratch that at this stage is too
ambitious for you.

After changing everything, add things. Adding more lights is a good place to
start. How about putting a sun in the sky? And how about adding more crystal
balls and having them “dance” around the scene?

Adding to an existing scene or animation is a good way to exercise your
imagination and build on your current skills. When you hit an impasse, when
you feel you are stuck because you can’t think how to achieve the effect you
are after, get out the main CINEMA 4D reference manual, read about all the
features that you think might be related to what you want to do, then experiment
with simple scenes and animations. If you want to see what effect a setting has
on an object, make a big change to the setting so the difference is obvious.

The secret to success here is remembering what changes have what effects. In
the early weeks and months with a creative program like CINEMA 4D it is so
easy to create an impressive effect and then completely forget how you did it.
So keep a record. Write down what you are doing. A couple of minutes recording
your actions could save hours of thrashing about trying to duplicate that neat
little effect you created three months ago.

And always remember that it is the manner in which you combine features and
settings that produce those very special effects that take the breath away. As a
small example, think back on how our tutorial animation changed when we
decided to make the little glowing light gradually change from red to yellow.
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The red light moving around looked nice, but when it changes from red to
yellow the scene around the crystal ball is set on fire spectacularly.

This is something which cannot be taught. It has to be discovered. All the tools
are here in CINEMA 4D, all you have to do is come up with innovative ways of
using them. We firmly believe that the speed and ease-of-use of CINEMA 4D
means that you will be producing expert scenes and animations faster than you
would with any other 3D or 4D modeller and raytracer.

Thank you for taking the time to read this book and follow along with the
tutorials. We are not going to wish you luck with your modelling, instead we
wish you swift inspirations.
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B. WHAT IS RAYTRACING?
Raytracing is the oldest and most elegant method of creating life-like images on
a computer. With the aid of laws of physics and mathematical formulas,
raytracing simulates the natural behaviour of light rays.

To start with a few thousand rays of a light source are selected, and their route
is traced. Some rays hit an object and will be reflected, refracted or absorbed.
Others will vanish into infinity or will hit upon the surface of the scene.
Eventually—directly, or indirectly via reflections—only a fraction of these rays
will end up on the focal plane of the imaginary camera (simulated by the screen
of the computer) and will create the corresponding pixels with the computed
brightness and colour.

It didn’t take long for people to realise that this method, though physically
correct, is far from efficient, especially since enormous numbers of rays have to
be calculated, none of which may even end up on the screen. So nowadays we
use the raytracing system the other way round. The rays start on the focal plane
of the camera. The program selects exactly those that pass through a pixel of
the monitor. The program traces the route of each ray through the scene until
it hits an object, the surface or the sky. It then computes the brightness of the
point of impact related to the lighting of the scene by the various light sources.

If shadows are to be computed then the program has to calculate rays from the
point of impact to all light sources in the scene in order to establish whether or
not there are one or more objects between the point of impact and the light
sources. If the program also has to compute reflections then it has to calculate
a reflected ray (originating from the point of impact) with subsequent new points
of impact, shadow rays, and so on. To calculate transparency and light refraction,
separate rays are needed. Thus the original ray branches out into more and
more reflected and refracted rays.

As the computing time and hard disk space of a computer are not infinite, the
program stops after a user-defined depth of branches is reached. When the
program reaches this cut-off point it averages the brightness of the established
points of impact to an overall brightness value for the pixel from which the ray
originated. In order to put colour on the screen, the brightness is calculated
separately for red, green and blue, the three primary colours.



86 CINEMA 4D QUICKSTART

Even though this method traces only those rays which are relevant to the
brightness of a pixel, the computations required are vast. The program has to
consider every object in a scene for every single ray, and then calculate the
intersections with that ray. The intersection nearest to the origin of the ray is
then selected.

Even a slow computer takes only a fraction of a second for such a calculation,
but an average scene would require several million of these computations so
you can see that even mainframe computers would not able to calculate
reasonable pictures in a reasonable time without the use of some kind of
accelerating method.

Among many other methods, one recently developed is known as the voxel
method.

Voxels
The voxel method minimises the computing time needed to calculate the
intersections. As many rays will intersect with only a few objects of the entire
scene, it is therefore desirable for the program to calculate only the intersections
with these few objects. In order to achieve this, the space in which the scene is
situated is divided into small cubes called voxels—a kind of 3D pixel.

The program will check in which of the voxels objects are found, and will
remember which objects are in which voxels. When the program wants to
calculate which objects a certain ray will hit, it now simply has to look up
which voxels are passed by the ray on its path. Empty voxels will be disregarded.
An intersection computation with the few objects within a voxel are needed
only when the program finds a full voxel. All other objects are no longer
considered. An enormous amount of time is saved using this method.

CINEMA 4D goes even further in its quest for the fastest possible rendering
times. The raytracer used by CINEMA 4D is known as an adaptive raytracer. In
many areas of a picture no calculation of reflected or transmitted rays is needed;
so in these areas the raytracer automatically switches to the faster scanline
method of rendering, thus saving even more computing time.
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C. RENDERING TIME SAVERS
• Switch off reflections.

• Switch off transparency.

• Switch off shadows.

• Use soft shadows instead of hard ones.

• Use Floor & Sky reflections instead of All Objects (or use environment
mirrors, which can be computed extremely quickly).

• Use Edges & Colours instead of Always when selecting an antialiasing mode.

• Don’t set the Threshold value below 15%.

• When the picture allows it, switch off the the Fresnel option.

• Construct models using squares instead of triangles.

• Avoid using light sources that create shadows. Light sources that don’t
create shadows take relatively little time to compute.

• Keep in mind that objects which are distant in a scene can be constructed
using simpler techniques (fewer segments, for example).

• Don’t overload your models with bump maps. Use bump maps only when
they really enhance the picture.

• Split-up your scenes where possible. When computing a complex animation
you can save a lot of time by excluding non-visible or non-relevant objects
when using certain camera angles.
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D. STUNNING SCENES
When you work with CINEMA 4D you have to be modeller, director, lighting
technician, cameraman, editor and a whole lot more all in one. There is no
substitute for experience, but we can give you some general guidelines.

Learn to Observe
Start looking at advertisements and films with a new and detailed eye. If you
see something of interest on the TV, videotape it and study it frame by frame.
Pay special attention to where the light is coming from and what colour filters
have been used. Perhaps one corner of the scene is emphasised?

In short, ask yourself: How do the professionals do it? Study what you see and
then try to emulate it. Never hesitate to enhance your pictures using a painting
program. (It’s not cheating!)

Light is the Key
The quality of a scene largely depends on the lighting. Clever use of light can
make up for a less than perfect scene. On the other hand, poorly considered
lighting can make a brilliantly constructed scene appear unrealistic, as if it has
been made out of plastic. So don’t spare the lighting effects, but think about
what you are doing.

A common accident that beginners have is making the scene too bright.
Remember, each light source adds to the overall lighting of the scene so, if you
have lots of lights, reduce the brightness of each.

Use coloured light. Sunlight, for example, is a bit yellowish during the day and
redder towards evening.

For every scene use at least one light source that does not light the scene directly,
but from behind or from the side. This way the scene looks more realistic. The
standard camera “flash” light is useful while constructing scenes but is not suitable
for high quality pictures.

Please make full use of fading light, spotlights, light maps, lens flares and light
halos, but keep in mind that another common mistake made by beginners to
modelling and rendering is the overuse of lens flares. For well over a hundred
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years optical engineers and photographers have been trying to eliminate these
refractive artifacts from camera lenses, so easy does it, eh?

Don’t forget about visual light, by the way! Visual light—a torch beam piercing
the darkness, for example, can enhance even the dullest of scenes, and as
visual light does not add to the scene lighting it costs next to no extra computing
time.

Above all, use your camera position in a creative way. For example, tilting your
camera angle will almost always create a more dynamic picture.
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